Antivirus updater

Antivirus updater 1.1.11
Запуск и обновлениe антивирусных Live CD/USB

Antivirus updater - скрипт для обновления баз антивирусных дистрибутивов Live CD/USB. Он позволяет обновлять базы в ISO образах с последующей их дефрагментацией, так и россыпь файлов. Присутствуют две локализации скрипта - русская и английская, определяется автоматом в зависимости от языка интерфейса пользователя. Для русского интерфейса - русская локализация, во всех других случаях английская. Antivirus updater работает на XP/2003 x86-x64 и старше.

Поддерживаемые дистрибутивы:
- Avira Rescue System (~628 Мб)
- Kaspersky Rescue Disk (~265 Мб)
- Bitdefender Rescue CD (~636 Мб)
- Dr.Web LiveDisk (~609 Мб)
- Dr.Web LiveCD (276 Мб)
- VBA32 Rescue (~172 Мб)

Antivirus updater работает на основе файла настроек - Setting.ini, который должен находится рядом. Записи в нем имеют следующий вид - имя_параметра=значение_параметра. Строки начинающиеся с ";" игнорируются.

Параметры Setting.ini:
Iso - полный путь к ISO образу антивирусного дистрибутива.
Av - полный путь к россыпи файлов антивирусного дистрибутива, может содержать не один антивирус.
DrWebKey - полный путь к лицензионному ключу для обновления его в Dr.Web LiveDisk/LiveCD.
Proxy - адрес прокси сервера в формате [адрес]:[порт].
Proxy_user - имя для доступа к прокси, если требуется.
Proxy_password - пароль для доступа к прокси, если требуется.
DontCheckUpdate=Yes - отключение поиска новых версий Antivirus updater.
DontDefragmentImages=Yes - отключение дефрагментации ISO образов.

Указывая путь в значении параметра можно использовать символ "$", он означает букву диска на котором запущен скрипт.
Таким образом поместив Antivirus updater на загрузочную флешку/USB-HDD его можно использовать на разных компьютерах, не опасаясь того что буква диска изменится и пути станут неправильными. Пути содержащие пробелы заключать в кавычки не нужно, имена параметров можно писать в любом регистре (Iso, IsO, ISO...). Параметры с неверным значением в пути/имени файла игнорируются. При использовании кириллицы в Setting.ini, файл должен быть сохранен в ОЕМ 866 кодировке.

Пример Setting.ini:
[Proxy Setting]
;Proxy=10.0.0.1:3128
;Proxy_user=kav
;Proxy_password=kav

[Antivirus]
Iso=$:\Boot\DrWeb-LiveDisk.iso
Iso=$:\Boot\Bitdefender.iso
AV=$:\

В примере указаны пара образов с относительными путями, каталог с таким же путем (проще говоря корень диска) в котором расположен Avira и VBA32, благо у них файлы не пересекаются. Настройки прокси закомментированы, использовал когда тестировал на работе. А надписи в квадратных скобках чисто для красоты.

Примечание:
В Avira Rescue System запрос на согласие с лицензионным соглашением отключен.
Можно обновлять базы в каталоге "Kaspersky Rescue Disk 10.0" через параметр AV.
Дистрибутив Dr.Web LiveCD больше не обновляется разработчиком, поэтому для работы сканера нужно задать DrWebKey (подойдет от Security Space).

Гибридная загрузка ISO:
На флешках и USB-HDD под управлением Grub4Dos антивирусные дистрибутивы можно запускать прямо из ISO. Причем файловая система может быть любой из поддерживаемых Grub4Dos-ом. Для этого используется гибридная загрузка образа, где по мимо обычного мапинга образ монтируется как один из разделов загрузочного устройства. Если раздел уже используется - он будет затерт. В примерах приведенных ниже, команда partnew пишет данные образа в 4-й раздел, как самый редко используемый. Гибридная загрузка не работает на виртуальных машинах или после Plop-а, потому что USB устройство переходит в режим "только чтение".

title Avira Rescue System
partnew (%@root:~1,3%,3) 0x00 /Boot/Avira.iso
map /Boot/Avira.iso (0xff)
map --hook
kernel (0xff)/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
initrd (0xff)/casper/initrd.lz

title Kaspersky Rescue Disk
partnew (%@root:~1,3%,3) 0x00 /Boot/Kaspersky.iso
map /Boot/Kaspersky.iso (0xff)
map --hook
kernel (0xff)/boot/rescue root=live:CDLABEL=KRD10 rootfstype=auto vga=791 init=/init kav_lang=ru udev liveimg splash quiet doscsi nomodeset
initrd (0xff)/boot/rescue.igz

title Bitdefender Rescue CD
partnew (%@root:~1,3%,3) 0x00 /Boot/Bitdefender.iso
map /Boot/Bitdefender.iso (0xff)
map --hook
kernel (0xff)/boot/kernel.i386-pc root=/dev/ram0 real_root=/dev/loop0 loop=/rescue/livecd.squashfs cdroot_marker=/rescue/livecd.squashfs initrd udev cdroot scandelay=10 quiet slash lang=en
initrd (0xff)/boot/initfs.i386-pc

title Dr.Web LiveDisk
partnew (%@root:~1,3%,3) 0x00 /Boot/DrWeb-LiveDisk.iso
map /Boot/DrWeb-LiveDisk.iso (0xff)
map --hook
kernel (0xff)/casper/vmlinuz boot=casper locale=ru_RU.UTF-8 quiet splash --
initrd (0xff)/casper/initrd.lz

title Dr.Web LiveCD
partnew (%@root:~1,3%,3) 0x00 /Boot/DrWeb-LiveCD.iso
map /Boot/DrWeb-LiveCD.iso (0xff)
map --hook
cat --skip=85 (0xff)/boot/config | set ID=
kernel (0xff)/boot/vmlinuz %ID% root=/dev/ram0 init=/linuxrc init_opts=4 quiet vga=791 splash=silent,theme:drweb CONSOLE=/dev/tty1 BOOT_LANG=ru_RU.UTF-8
initrd (0xff)/boot/initrd

title VBA32 Rescue
map /Boot/VBA32.iso (0xff)
partnew (%@root:~1,3%,3) 0x00 /Boot/VBA32.iso
map --hook
kernel (0xff)/vba/kernel vga=791 quiet
initrd (0xff)/vba/initrd

Что нового в 1.1.11 версии:
- Исправлено обнoвление Avira Rescue System.

Что нового в 1.1.10 версии:
- Исправлено отображение количества обновленных баз в Kaspersky Rescue Disk.
- Обновлен 7-Zip, Squashfs Tools.

Что нового в 1.1.8 версии:
- Добавлена возможность обновления баз в каталоге "Kaspersky Rescue Disk 10.0".
- Исправлена работа AV параметра, когда в значении был указан системный раздел.
- Исправлены некоторые ошибки обновления Kaspersky Rescue Disk.
- Обновлен wget, mkisofs.

Antivirus_updater.exe (5,3 Мб) MD5: 6B7F867411F63514E0277664286E6D92
RGhost, MediaFire, Rusfolder.

drweb32.key - забаненый ключ для Dr.Web LiveCD до 16.04.2017. Сканер будет работать, а вот скачать обновления силами самого антивируса уже не получиться.

Сайт: http://forum.ru-board.com/topic.cgi?forum=5&topic=32855&start=9670&limit=1